Mega Coleção 6Volumes 2GB

RPG Maker VX Ace ganha Service Pack 1!

É, para quem não sabia, agora já temos mais um script com as correções e um patch de atualizações, dessa vez oficiais, vindas diretamente da Enterbrain.

É o script chamado VXAce_SP1, que corrige 8 bugs, e já está disponível para [download] no site oficial da Enterbrain. Junto com ele foi lançada um patch corretor que  traz atualizações na biblioteca do RGSS e na interface do programa, deixando-o na versão 1.01a.

Bastaria por hora trazer o script completo para vocês, não é? Mas como aqui fazemos um pouquinho mais de serviço, decidimos trazer além dele, alguns dos arquivos novos para que você mantenha seu RPG Maker ainda mais atualizado.

No total, foram apenas 4 arquivos atualizados, e o patch só roda se você tiver a versão em japonês completa do RPG Maker VX Ace em japonês completa (full) . Ainda não foi confirmado se o patch funciona com a versão em inglês oficial, até por que não sabemos que diferenças tem entre essa versão e a japonesa. Mas de toda forma ele não funcionará com a versão distribuída aqui pela Condado.

Os arquivos são esses: RGSS301.dll (novo), RPGVXAce.exe, RPGVXAce.chm e RPGVXAceJPN.dll(atualizados). Mas infelizmente para que todos arquivos sejam usados, é requerido que seja feita uma ativação do produto, pois o novo executável do programa recebeu reforços quanto ao sistema de proteção. Talvez façamos retradução da RPGVXAceJPN, mas isso é aparentemente desnecessário.

Isso por quê testes aqui reportam que o novo executável funciona com a DLL antiga já traduzida, mesmo com a persistência do “problema” da ativação online. Não se sabe quais alterações sofreu o arquivo de ajuda. Por isso por hora só disponibilizamos a nova biblioteca, e o novo arquivo de ajuda (que infelizmente ainda continua em japônes), e os scripts.

Você pode baixá-los todos de uma vez [nesse link]. Para atualizar o arquivo de ajuda basta colar o novo arquivo na pasta em que você instalou o seu RPG Maker, substituindo o antigo. Para usar a nova biblioteca RGSS, é recomendável colocar ela na pasta System do seu projeto, e alterar a terceira linha do seu Game.ini (que pode ser editado com o Bloco de Notas). Coloque Library=System\RGSS301.dll

Já para o script, basta abrir, copiar seu conteúdo, e colar em uma novo script, que deve ser criado após Materiais, e acima de Main. No momento não se sabe a compatibilidade desse script com outros, nem com os scripts de correção do Yanfly, lançados aqui anteriormente. Mas achamos que deve funcionar corretamente na maioria dos casos. Só não se esqueça de fazer backups dos seus dados antes de testar!

A equipe da Condado começará a trabalhar a partir de agora para traduzir tudo e quebrar as proteções, para que todos os makers possam desfrutar das atualizações mais recentes. Fiquem ligados, que em breve teremos mais novidades!

11 respostas a RPG Maker VX Ace ganha Service Pack 1!

Deixar uma resposta

Relógio

Qual o gênero RM que você mais gosta?


RESULTADO

Loading ... Loading ...

Top Screens

wait
wait

Vídeo RM Destaque